Error 4808 on Custom Indi Module

Avatar
  • updated
  • Not a bug

It works perfectly in testing mode. But when I attach it to a demo account error 4808 occurs. (MT5 log at the bottom):

Image 4675

Any ideas?

Link to Indicator:

https://www.mql5.com/de/code/22218

How would you rate the customer service you received?

Satisfaction mark by Jan Corsair 10 months ago

Add a comment about quality of support you received (optional):

Pinned replies
Avatar
0
Andrey Khatimlianskyi
  • Answer
  • Not a bug

Okay.

I have studied this issue.
The problem is the large number of input parameters of the indicator. If I comment out most of them, the EA can successfully load it.

So the solution to the problem is to reduce the number of input parameters.
To do this, open the indicator file (HarmonicPatternFinderV3.mq5), then go to the file " HPFGlobals.mqh" and open it, and then delete the keyword 'input' before the unnecessary input parameters. Here you can also set default values for all input parameters.
Finally, go to the main indicator file and compile it.

Image 4695

I hope this helps.

Avatar
0
ferdinand tampubolon

indicator path wrong bro..

put like this

HarmonicPatternFinfderV3

if download at market mql5

put like this

\Market\Dark Point MT5 ( example)

Avatar
0
Jan Corsair
Quote from ferdinand tampubolon

indicator path wrong bro..

put like this

HarmonicPatternFinfderV3

if download at market mql5

put like this

\Market\Dark Point MT5 ( example)

It works perfectly in testing mode. Problem is related to live (demo) account.


Error 4802 seems to be related to a wrong path. Error 4808 is something else. (I guess)

Avatar
0
ferdinand tampubolon
Quote from Jan Corsair

It works perfectly in testing mode. Problem is related to live (demo) account.


Error 4802 seems to be related to a wrong path. Error 4808 is something else. (I guess)

indicator parameter is zero bro

and path is worng bro need place in mql folder inside indicator folder bro

Avatar
0
Jan Corsair
Quote from ferdinand tampubolon

indicator parameter is zero bro

and path is worng bro need place in mql folder inside indicator folder bro

I tried around with different paths and setting. Try it yourself if you don't belive me. It's a bug. And please vote it up if you tried it and have the same result.

Avatar
2
Ulises Cune
Avatar
1
Andrey Khatimlianskyi
  • Under review

Jan, please attach your set file so I can check what was wrong.

4808 means "Wrong number of parameters when creating an indicator", so it is really looks like a bug. Let's check it.

Avatar
0
Jan Corsair

Thanks for your support guys.

@Ulises: Your setfile gives me an error on init (while testing) bescause my HPFV3 is in an other path. Modifing the path solves problem in "testing" but not in demo account. (It is the same with my setfile)

Here is my setfile:  Patterns 1.set


Please keep in mind that this problem is only related to real/demo accounts. It works perfectly in strategy tester.

Thanks for looking into it Andrey. :-)

Avatar
1
ferdinand tampubolon

Image 4688

Image 4692

HarmonicPatternFinderV3.ex5
harmonikv3 set la.set

cannot run .. ea will remove by it self...

Avatar
0
Andrey Khatimlianskyi
  • Answer
  • Not a bug

Okay.

I have studied this issue.
The problem is the large number of input parameters of the indicator. If I comment out most of them, the EA can successfully load it.

So the solution to the problem is to reduce the number of input parameters.
To do this, open the indicator file (HarmonicPatternFinderV3.mq5), then go to the file " HPFGlobals.mqh" and open it, and then delete the keyword 'input' before the unnecessary input parameters. Here you can also set default values for all input parameters.
Finally, go to the main indicator file and compile it.

Image 4695

I hope this helps.

Avatar
0
Jan Corsair

I removed "input" from the "color" parameters, I guess the other values are relevant.

Image 4697

I compiled it and now get this (when attached to account):

Image 4696